Skyler Grey | f08a619 | 2024-06-01 23:55:20 +0000 | [diff] [blame^] | 1 | # SPDX-FileCopyrightText: 2024 Auxolotl Infrastructure Contributors |
| 2 | # SPDX-FileCopyrightText: 2024 Clicks Codes |
| 3 | # |
| 4 | # SPDX-License-Identifier: GPL-3.0-only |
| 5 | |
| 6 | { |
| 7 | description = "Auxolotl infrastructure."; |
| 8 | |
| 9 | inputs = { |
| 10 | nixpkgs.url = "github:nixos/nixpkgs/nixos-24.05"; |
| 11 | unstable.url = "github:nixos/nixpkgs/nixos-unstable"; |
| 12 | |
| 13 | snowfall-lib = { |
| 14 | url = "github:snowfallorg/lib/dev"; |
| 15 | inputs.nixpkgs.follows = "nixpkgs"; |
| 16 | }; |
| 17 | |
| 18 | deploy-rs = { |
| 19 | url = "github:serokell/deploy-rs"; |
| 20 | inputs.nixpkgs.follows = "nixpkgs"; |
| 21 | }; |
| 22 | }; |
| 23 | |
| 24 | outputs = |
| 25 | inputs: |
| 26 | let |
| 27 | lib = inputs.snowfall-lib.mkLib { |
| 28 | inherit inputs; |
| 29 | |
| 30 | src = ./.; |
| 31 | |
| 32 | snowfall = { |
| 33 | namespace = "clicks"; |
| 34 | }; |
| 35 | }; |
| 36 | in |
| 37 | lib.mkFlake { |
| 38 | overlays = with inputs; [ ]; |
| 39 | |
| 40 | deploy = lib.mkDeploy { |
| 41 | inherit (inputs) self; |
| 42 | overrides = { |
| 43 | a1d1.hostname = "d1.a1.clicks.domains"; |
| 44 | }; |
| 45 | }; |
| 46 | |
| 47 | checks = builtins.mapAttrs ( |
| 48 | system: deploy-lib: deploy-lib.deployChecks inputs.self.deploy |
| 49 | ) inputs.deploy-rs.lib; |
| 50 | |
| 51 | outputs-builder = channels: { formatter = channels.nixpkgs.nixfmt-rfc-style; }; |
| 52 | }; |
| 53 | } |