Skyler Grey | f08a619 | 2024-06-01 23:55:20 +0000 | [diff] [blame^] | 1 | # SPDX-FileCopyrightText: 2024 Auxolotl Infrastructure Contributors |
2 | # SPDX-FileCopyrightText: 2024 Clicks Codes | ||||
3 | # | ||||
4 | # SPDX-License-Identifier: GPL-3.0-only | ||||
5 | |||||
6 | { lib, config, ... }: | ||||
7 | let | ||||
8 | cfg = config.clicks.services.ssh; | ||||
9 | in | ||||
10 | { | ||||
11 | options.clicks.services.ssh = { | ||||
12 | enable = lib.mkEnableOption "SSH"; | ||||
13 | }; | ||||
14 | |||||
15 | config = lib.mkIf cfg.enable { | ||||
16 | services.openssh = { | ||||
17 | enable = true; | ||||
18 | }; | ||||
19 | }; | ||||
20 | } |