| stdenv.mkDerivation rec { |
| pname = "nerdfonts-glyphs"; |
| # This uses a sparse checkout because the repo is >2GB without it |
| sparseCheckout = [ "/src/glyphs" ]; |
| sha256 = "sha256-boZUd1PM8puc9BTgOwCJpkfk6VMdXLsIyp+fQmW/ZqI="; |
| mkdir -p $out/bin $out/share/fonts/truetype |
| mkdir -p $out/bin $out/share/fonts/opentype |
| find . -name "*.ttf" -exec mv {} $out/share/fonts/truetype \; |
| find . -name "*.otf" -exec mv {} $out/share/fonts/opentype \; |
| description = "A nerd-fonts copy that only includes the glyphs (rather than patching)"; |
| homepage = "https://nerdfonts.com/"; |
| maintainers = with maintainers; [ minion3665 ]; |