| { config, pkgs, nixpkgs }: |
| variables = import ./common/variables.nix; |
| name = builtins.replaceStrings [ ".nix" ] [ "" ] file; |
| value = import (./. + "/pkgConfigs/${file}") { }; |
| pkgs.lib.mapAttrs' toPkg (builtins.readDir (./. + "/pkgConfigs")); |
| { imports = generatedPkgs; } |
| ./apps/personal/steam.nix |
| (import ./overlays/anytype.nix) |
| home.packages = with pkgs; [ # New apps should be on new lines |
| git-crypt gnupg pinentry_qt |
| nur.repos.kira-bruneau.rofi-wayland |
| ]; # Use *only* for packages that need no configuration; |
| # other packages should go in ./apps/personal/ |
| home.stateVersion = variables.stateVersion; |