| username_cmd = "${pkgs.coreutils}/bin/cat ${config.sops.secrets.spotifyUsername.path}"; |
| password_cmd = "${pkgs.coreutils}/bin/cat ${config.sops.secrets.spotifyPassword.path}"; |
| device_name = "background@${config.networking.hostName}"; |
| cache_path = "${home.home.homeDirectory}/.cache/spotifyd"; |
| max_cache_size = 1000000000; |
| volume_normalisation = true; |
| normalisation_pregain = -10; |
| device_type = "computer"; |
| home.packages = [ pkgs.spotify-tui ]; |
| sops.secrets.spotifyUsername = { |
| owner = config.users.users.${username}.name; |
| group = config.users.users.nobody.group; |
| sops.secrets.spotifyPassword = { |
| owner = config.users.users.${username}.name; |
| group = config.users.users.nobody.group; |
| sops.secrets.sptConfig = { |
| owner = config.users.users.${username}.name; |
| group = config.users.users.nobody.group; |
| path = "${home.home.homeDirectory}/.config/spotify-tui/client.yml"; |
| sopsFile = ../secrets/spotify-tui.yml.bin; |
| environment.persistence."/nix/persist".users.${username}.directories = [ |