blob: 55f8fd4e2435c8a4a3b6b3c7c3aa84afe796fb9e [file] [log] [blame]
{
pkgs,
lib,
...
}: {
programs.neovim = {
plugins = with pkgs.vimPlugins; [
neoformat
];
extraConfig = builtins.readFile ./setup.vim;
extraPackages = with pkgs; [
nodePackages.prettier
alejandra
rustfmt
shfmt
astyle
uncrustify
];
};
home.sessionVariables.UNCRUSTIFY_CONFIG = ./uncrustify.cfg;
}