Gitiles
Code Review
Sign In
git.clicks.codes
/
Minion
/
NixFiles
/
537932e6553adcb7ba530a8f033da3b6846ef82d
/
.
/
utils
/
interpolateFile.nix
blob: 36650965f9917da9196b5c9c606c9c113bcb9ce7 [
file
] [
log
] [
blame
]
{
utils
,
pkgs
}:
file
:
pkgs
.
lib
.
pipe file
[
utils
.
readFile
(
text
:
pkgs
.
writeTextFile
{
name
=
builtins
.
baseNameOf file
;
inherit text
;
executable
=
true
;
# TODO: write and use utils.isExecutable
})
]