| # Do not modify this file! It was generated by ‘nixos-generate-config’ |
| # and may be overwritten by future invocations. Please make changes |
| # to /etc/nixos/configuration.nix instead. |
| { config, lib, pkgs, modulesPath, ... }: |
| |
| { |
| imports = |
| [ (modulesPath + "/installer/scan/not-detected.nix") |
| ]; |
| |
| boot.initrd.availableKernelModules = [ "xhci_pci" "ahci" "nvme" "usbhid" "sd_mod" ]; |
| boot.initrd.kernelModules = [ ]; |
| boot.kernelModules = [ "kvm-intel" ]; |
| # boot.extraModulePackages = [ config.boot.kernelPackages.exfat-nofuse ]; # Broken in nixpkgs; seems to be mountable and usable anyway |
| |
| fileSystems."/" = |
| { device = "/dev/disk/by-label/nixos"; |
| fsType = "ext4"; |
| }; |
| |
| fileSystems."/boot" = |
| { device = "/dev/disk/by-label/boot"; |
| fsType = "vfat"; |
| }; |
| |
| swapDevices = |
| [ { device = "/dev/disk/by-label/swap"; } |
| ]; |
| |
| powerManagement.cpuFreqGovernor = lib.mkDefault "powersave"; |
| hardware.cpu.intel.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware; |
| |
| # hardware.opentabletdriver.enable = true; |
| } |