| "suggest.noselect" = false; |
| "cSpell.checkOnlyEnabledfileTypes" = false; |
| "cSpell.dictionaryDefinitions" = [ |
| path = "${home.home.homeDirectory}/.local/share/cspell/dictionary.txt"; |
| "cSpell.dictionaries" = ["imperative"]; |
| "git.enableGutters" = false; # We're using another plugin to do this |
| "rust-analyzer.serverPath" = "${pkgs.rust-analyzer}/bin/rust-analyzer"; |
| command = "${pkgs.rnix-lsp}/bin/rnix-lsp"; |
| plugins = with pkgs.vimPlugins; [ |
| nixpkgs-minion.legacyPackages.${system}.vimPlugins.coc-spell-checker |
| coc-git # TODO: Check if coc-git is still needed |
| extraConfig = lib.pipe [./keybinds.vim ./theme.vim] [ |
| (builtins.concatStringsSep "\n") |
| extraPackages = [pkgs.nodejs pkgs.rustc pkgs.go]; |
| home.file = lib.pipe ./snippets [ |
| name = ".config/coc/ultisnips/${f}"; |
| source = ./snippets + "/${f}"; |
| target = ".config/coc/ultisnips/${f}"; |