blob: 2db4c6a92cfe4a82919938a7b0ab75eb1940c38b [file] [log] [blame]
{
pkgs,
lib,
...
}: {
programs.neovim = {
plugins = with pkgs.vimPlugins; [
neoformat
];
extraConfig = builtins.readFile ./setup.vim;
extraPackages = with pkgs; [
nodePackages.prettier
alejandra
rustfmt
shfmt
astyle
];
};
}