blob: 50630fcd3689558083eb33bc5cfe197ae53d0778 [file] [log] [blame]
{ pkgs, ... }: {
wayland.windowManager.sway = {
enable = true;
wrapperFeatures.gtk = true;
config = {
assigns = {};
bars = [];
colors = {};
};
};
home.packages = with pkgs; [
swaylock
swayidle
wl-clipboard
];
systemd.user.targets.sway-session.Unit = {
description = "Sway compositor session";
documentation = [ "man:systemd.special(7)" ];
bindsTo = [ "graphical-session.target" ];
wants = [ "graphical-session-pre.target" ];
after = [ "graphical-session-pre.target" ];
};
programs.zsh.profileExtra = ''
if [ -z $DISPLAY ] && [ "$(tty)" = "/dev/tty1" ]; then
exec systemd-cat -t sway sway
fi
'';
}