| version = "1ba013d3fe54de01c52bd74d98037fe4c0029d6e"; |
| src = final.fetchFromGitHub { |
| hash = "sha256-R1nCdua0gacXrglQ4AZfxnO3ngVECCKKiUOgp3dWRGg="; |
| hubfs = final.buildGoModule { |
| buildInputs = with final; [ |
| checkPhase = ":"; # Bit of a hack here; we need to disable tests as we can't get FUSE inside the build derivation to test the package |
| vendorSha256 = "sha256-sT3H1iFSakLHWKhzRcJz2RXf2Owm+8DQy3h3O8MO2nY="; |
| "-X main.GitVersion=${version}" |
| "-X main.GitVersionFuse=[vendored]" |
| "-X main.BuildDate=unknown" |
| wrapProgram $out/bin/hubfs \ |
| --suffix PATH : ${final.lib.makeBinPath [ final.fuse final.fuse3 ]} |
| ln -s $out/bin/hubfs $out/bin/mount.fuse.hubfs |
| description = "GitHub as a FUSE mount"; |
| license = licenses.agpl3; |
| homepage = "https://github.com/winfsp/hubfs"; |
| maintainers = with maintainers; [ minion3665 ]; |
| platforms = platforms.unix; |