| path = "${home.xdg.dataHome}/zsh/history"; |
| expireDuplicatesFirst = true; |
| bindkey "\'\'$\{key[Up]}" up-line-or-search |
| ZSH_AUTOSUGGEST_HIGHLIGHT_STYLE='fg=243'; |
| ZSH_HIGHLIGHT_STYLES[comment]='fg=248'; |
| if [[ $SHLVL != "1" ]]; then |
| export RPS1=$'%{\033[38;5;248m%}(%{$fg[red]%}L$SHLVL%{\033[38;5;248m%})%{\033[39m\033[49m%} ' |
| # disable sort when completing `git checkout` |
| zstyle ':completion:*:git-checkout:*' sort false |
| # set descriptions format to enable group support |
| zstyle ':completion:*:descriptions' format '[%d]' |
| # set list-colors to enable filename colorizing |
| zstyle ':completion:*' list-colors ''${(s.:.)LS_COLORS} |
| # preview directory's content with exa when completing cd |
| zstyle ':fzf-tab:complete:cd:*' fzf-preview 'exa -1 -l --color=always $realpath' |
| # switch group using `,` and `.` |
| zstyle ':fzf-tab:*' switch-group ',' '.' |
| source "${./zsh/completions/bun.zsh}" |
| enableSyntaxHighlighting = true; |
| enableAutosuggestions = true; |
| config.environment.persistence."/nix/persist".users.${username}.directories = [".local/share/zsh"]; |