Add sway and waybar; add personal scripts (hopefully)
diff --git a/src/apps/personal/sway.nix b/src/apps/personal/sway.nix
new file mode 100644
index 0000000..255560b
--- /dev/null
+++ b/src/apps/personal/sway.nix
@@ -0,0 +1,20 @@
+{ pkgs, ... }: {
+ wayland.windowManager.sway = {
+ enable = true;
+ wrapperFeatures.gtk = true;
+ };
+
+ home.packages = with pkgs; [
+ swaylock
+ swayidle
+ wl-clipboard
+ ]
+
+ systemd.user.targets.sway-session = {
+ description = "Sway compositor session";
+ documentation = [ "man:systemd.special(7)" ];
+ bindsTo = [ "graphical-session.target" ];
+ wants = [ "graphical-session-pre.target" ];
+ after = [ "graphical-session-pre.target" ];
+ };
+}
\ No newline at end of file