blob: 255560b35b8cf53f7ca4a28c5e0005d2431b9c2b [file] [log] [blame]
{ pkgs, ... }: {
wayland.windowManager.sway = {
enable = true;
wrapperFeatures.gtk = true;
};
home.packages = with pkgs; [
swaylock
swayidle
wl-clipboard
]
systemd.user.targets.sway-session = {
description = "Sway compositor session";
documentation = [ "man:systemd.special(7)" ];
bindsTo = [ "graphical-session.target" ];
wants = [ "graphical-session-pre.target" ];
after = [ "graphical-session-pre.target" ];
};
}