blob: ed5721bf70b1f8deb6894e61578c2bee077649a5 [file] [log] [blame]
{ pkgs, ... }: {
programs.kitty = {
enable = true;
theme = "One Half";
};
programs.zsh.initExtra = ''
if test -n "$KITTY_INSTALLATION_DIR"; then
export KITTY_SHELL_INTEGRATION="enabled"
autoload -Uz -- "$KITTY_INSTALLATION_DIR"/shell-integration/zsh/kitty-integration
kitty-integration
unfunction kitty-integration
fi
'';
}