blob: a27e478fa8db3e471c334844055619153ab281c4 [file] [log] [blame]
{impermanence, ...}: {
imports = [
impermanence.nixosModules.impermanence
];
config = {
environment.persistence."/nix/persist" = {
hideMounts = true;
};
environment.persistence."/large/persist" = {
hideMounts = true;
};
fileSystems."/" = {
device = "none";
fsType = "tmpfs";
options = ["defaults" "size=20G" "mode=755"];
};
fileSystems."/boot" = {
device = "/dev/disk/by-label/BOOT";
fsType = "vfat";
};
fileSystems."/nix" = {
device = "/dev/mapper/nix";
fsType = "ext4";
neededForBoot = true;
};
fileSystems."/large" = {
device = "/dev/mapper/hdd";
neededForBoot = true;
fsType = "ext4";
};
swapDevices = [
{device = "/dev/mapper/swap";}
];
boot.initrd.availableKernelModules = ["nvme"];
};
}