blob: 77f5f66eb57c121b729082589b18084ef790b3dd [file] [log] [blame]
Skyler Grey2a7ca382022-09-01 23:15:31 +01001{
2 pkgs,
3 username,
4 gtimelog,
5 lib,
6 ...
7}: {
8 home.home = {
9 packages = [
10 (pkgs.gtimelog.overrideAttrs (oldAttrs: {
11 src = gtimelog;
12 makeWrapperArgs = [
13 "--set GI_TYPELIB_PATH ${lib.makeSearchPathOutput "lib"
14 "lib/girepository-1.0" (with pkgs; [
15 gtk3
16 libsoup
17 libsecret
18 pango
19 harfbuzz
20 gdk-pixbuf
21 atk
22 ])}"
23 "--set GIO_MODULE_DIR ${lib.makeSearchPathOutput "out"
24 "lib/gio/modules" (with pkgs; [
25 glib-networking
26 ])}"
27 ];
28 buildInputs = oldAttrs.buildInputs ++ [pkgs.glib-networking];
29 }))
30 ];
31 file.".gtimelog/gtimelogrc".source = ./gtimelog/gtimelogrc.toml;
32 };
33
34 config.environment.persistence."/nix/persist".users.${username}.directories = [".gtimelog"];
35}