blob: 44fcdc0fda52d9fb642a6afab782bd1a07c3b8fe [file] [log] [blame]
Skyler Greyab59d172022-10-30 23:23:31 +00001{
2 lib,
3 fetchFromGitHub,
4 buildDotnetPackage,
5 pkg-config,
6 dotnet-sdk,
7 dotnetPackages,
8 msbuild,
9}: let
10 rev = "4fdada72e9a08a810da8e332258ae0dcc7e89cc7";
11in
12 buildDotnetPackage rec {
13 pname = "csharp-ls";
14 version = "1.0.0";
15 src = fetchFromGitHub {
16 owner = "razzmatazz";
17 repo = "csharp-language-server";
18 inherit rev;
19 sha256 = "sha256-+fc1mlNG9rxqQXaQXsGY228hz7zu2zaj3NlfDlNdn8U=";
20 };
21 projectFile = "src/csharp-language-server.sln";
22 buildInputs = [
23 msbuild
24 dotnet-sdk
25 dotnetPackages.NUnit
26 dotnetPackages.NUnitRunners
27 ];
28 nativeBuildInputs = [
29 pkg-config
30 ];
31 nugetDeps = ./csharp-ls/deps.nix;
32 buildPhase = ''
33 runHook preBuild
34
35 msbuild ${projectFile} /p:Configuration=Release
36 runHook postBuild
37 '';
38 meta = with lib; {
39 homepage = "https://github.com/razzmatazz/csharp-language-server";
40 description = "A csharp language server";
41 license = licenses.mit;
42 maintainer = [maintainers.minion3665];
43 };
44 }