blob: 4c9dfaf1165787182d4f601c140a1595ede21cc1 [file] [log] [blame]
Skyler Turner205aff12021-12-20 11:22:57 +00001# Edit this configuration file to define what should be installed on
2# your system. Help is available in the configuration.nix(5) man page
3# and in the NixOS manual (accessible by running ‘nixos-help’).
4
5{ config, pkgs, lib, ... }:
6
7{
8 imports =
9 [ # Include the results of the hardware scan.
10 ./hardware-configuration.nix
Skyler Turner444ffc22021-12-20 11:28:06 +000011 ../secrets/networking-configuration.nix
Skyler Turner205aff12021-12-20 11:22:57 +000012 ./packaging-configuration.nix
13# ./eduroam.nix
14 ];
15
Skyler Turner32dbfb42021-12-24 15:50:22 +000016 # Prepare nix flakes
17 nix = {
18 package = pkgs.nixFlakes;
19 extraOptions = ''
20 experimental-features = nix-command flakes
21 '';
22 };
23
Skyler Turner205aff12021-12-20 11:22:57 +000024 # Use the systemd-boot EFI boot loader.
25 boot.loader.systemd-boot.enable = true;
26 boot.loader.efi.canTouchEfiVariables = true;
27 boot.loader.grub.useOSProber = true;
28
Skyler Turner7b0051e2021-12-29 15:46:56 +000029 # Enable emulated systems
Skyler Turner107ae412021-12-29 18:34:59 +000030 boot.binfmt.emulatedSystems = [ "aarch64-linux" "armv6l-linux" ];
Skyler Turner7b0051e2021-12-29 15:46:56 +000031
Skyler Turner205aff12021-12-20 11:22:57 +000032 # Enable apparmor
33 security.apparmor.enable = true;
34 security.apparmor.killUnconfinedConfinables = true;
35
36 # Set your time zone.
37 time.timeZone = "Europe/London";
38
39 # Select internationalisation properties.
40 i18n.defaultLocale = "en_US.UTF-8";
41 console = {
42 font = "Lat2-Terminus16";
43 keyMap = "uk";
44 };
45
46 # Enable the X11 windowing system.
47 services.xserver = {
48 enable = true;
49 desktopManager = {
50 xterm.enable = false;
51 # xfce.enable = true;
52 };
Skyler Turnerf0e4f3e2022-01-09 13:46:00 +000053 # displayManager.startx.enable = true;
54 displayManager.sddm.enable = true;
Skyler Turner205aff12021-12-20 11:22:57 +000055 };
56
57 # And wayland
58 programs.sway = {
59 enable = true;
60 wrapperFeatures.gtk = true; # so that gtk works properly
61 extraPackages = with pkgs; [
62 swaylock
63 swayidle
64 wl-clipboard
65 mako # notification daemon
66 alacritty # Alacritty is the default terminal in the config
Skyler Turner205aff12021-12-20 11:22:57 +000067 ];
68 };
69
70 # Get screensharing to work
71 xdg = {
72 portal = {
73 enable = true;
74 extraPortals = with pkgs; [
75 xdg-desktop-portal-wlr
76 xdg-desktop-portal-gtk
77 ];
78 gtkUsePortal = true;
Skyler Turner84ec77c2022-01-14 09:05:57 +000079 wlr.enable = true;
80
Skyler Turner205aff12021-12-20 11:22:57 +000081 };
82 };
83
84 # Configure keymap in X11
85 services.xserver.layout = "gb";
86 # services.xserver.xkbOptions = "eurosign:e";
87
88
89 # Permit and install steam
90 nixpkgs.config.allowUnfreePredicate = pkg: builtins.elem (lib.getName pkg) [
91 "steam"
92 "steam-original"
93 "steam-runtime"
94 ];
95
96 programs.steam.enable = true;
97
98
99 # Enable CUPS to print documents.
100 services.printing.enable = true;
101
102 # Enable sound.
103 sound.enable = true;
104 hardware.pulseaudio.enable = false;
105 services.pipewire = {
106 enable = true;
107 alsa = {
108 enable = true;
109 support32Bit = true;
110 };
111 pulse.enable = true;
112 };
113
114 # Enable touchpad support (enabled default in most desktopManager).
115 services.xserver.libinput.enable = true;
116
117 # Define a user account. Don't forget to set a password with ‘passwd’.
118 users.users.minion = {
119 isNormalUser = true;
120 extraGroups = [ "wheel" ]; # Enable ‘sudo’ for the user.
121 };
122
123 # List packages installed in system profile. To search, run:
124 # $ nix search wget
125 environment.systemPackages = with pkgs; [
126 vim # Do not forget to add an editor to edit configuration.nix! The Nano editor is also installed by default.
127 ((emacsPackagesNgGen emacs).emacsWithPackages (epkgs: [
128 epkgs.vterm
129 epkgs.emacsql-sqlite
130 ])) # Emacs + vterm-module (needed for vterm)
131 wget
132 firefox
133 chromium # Install chromium if needed
134 texlive.combined.scheme-full
135 keybase # Install keybase
136 keybase-gui
137 kbfs
Skyler Turneree73be42022-01-10 11:02:46 +0000138 bluez
Skyler Turner0f02e162022-01-14 21:09:05 +0000139 mate.mate-polkit
Skyler Turner205aff12021-12-20 11:22:57 +0000140 ];
141
142# environment.systemPackages = [
143# import /scripts/jetbrains.rider.nix
144# ];
145
146 fonts.fonts = with pkgs; [
147 nerdfonts
148 noto-fonts
149 noto-fonts-cjk
150 noto-fonts-emoji
151 liberation_ttf
152 fira-code
153 fira-code-symbols
154 mplus-outline-fonts
155 dina-font
156 proggyfonts
157 roboto
158 ];
159
160 # Some programs need SUID wrappers, can be configured further or are
161 # started in user sessions.
162 programs.mtr.enable = true;
163 programs.gnupg.agent = {
164 enable = true;
165 enableSSHSupport = true;
166 };
167
168 # List services that you want to enable:
169
170 # Enable the OpenSSH daemon.
171 services.openssh.enable = true;
172 services.keybase.enable = true;
173 services.gnome.gnome-keyring.enable = true;
174 services.i2p.enable = true;
Skyler Turner32dbfb42021-12-24 15:50:22 +0000175 virtualisation.docker.enable = true;
Skyler Turnerf0e4f3e2022-01-09 13:46:00 +0000176 virtualisation.containerd.enable = true;
Skyler Turner205aff12021-12-20 11:22:57 +0000177
178 # This value determines the NixOS release from which the default
179 # settings for stateful data, like file locations and database versions
180 # on your system were taken. It‘s perfectly fine and recommended to leave
181 # this value at the release version of the first install of this system.
182 # Before changing this value read the documentation for this option
183 # (e.g. man configuration.nix or on https://nixos.org/nixos/options.html).
184 system.stateVersion = "21.11"; # Did you read the comment?
185
186}
187