blob: 58d452487c45d5ca9400e3001a9e9bbda46ca5cf [file] [log] [blame]
Skyler Greyffc104a2022-05-24 08:47:15 +01001# Modified from https://github.com/gytis-ivaskevicius/nixfiles/blob/5439c8f4d7ccaeed57150846b1ed8afa0b7063ed/overlays/default.nix, which is licensed under the MIT license
2# Below is a copy of that license:
3/*
4MIT License
5
6Copyright (c) 2021 Gytis Ivaskevicius
7
8Permission is hereby granted, free of charge, to any person obtaining a copy
9of this software and associated documentation files (the "Software"), to deal
10in the Software without restriction, including without limitation the rights
11to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
12copies of the Software, and to permit persons to whom the Software is
13furnished to do so, subject to the following conditions:
14
15The above copyright notice and this permission notice shall be included in all
16copies or substantial portions of the Software.
17
18THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
19IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
20FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
21AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
22LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
23OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
24SOFTWARE.
25*/
26# Therefore, this file is also copyable under MIT as it represents a "substantial portion" of the original code
27
28final: prev: {
29 discord = final.makeDesktopItem {
30 name = "Discord";
Skyler Grey6be95aa2022-05-24 10:00:59 +010031 desktopName = "Discord";
Skyler Greyffc104a2022-05-24 08:47:15 +010032 genericName = "All-in-one cross-platform voice and text chat for gamers";
Skyler Grey150ac0b2022-05-24 21:58:02 +010033 exec = "${final.chromium}/bin/chromium --app=\"https://discord.com/channels/@me\" --autoplay-policy=no-user-gesture-required --enable-features=WebUIDarkMode --force-dark-mode";
Skyler Greyffc104a2022-05-24 08:47:15 +010034 icon = "discord";
35 type = "Application";
36 categories = "Network;InstantMessaging;";
37 terminal = "false";
38 mimeType="x-scheme-handler/discord";
39 };
40
Skyler Grey4a86fe72022-05-24 09:55:22 +010041 element-desktop-wayland = final.makeDesktopItem {
Skyler Greyffc104a2022-05-24 08:47:15 +010042 name = "Element";
43 desktopName = "Element";
44 genericName = "Secure and independent communication, connected via Matrix";
Skyler Grey150ac0b2022-05-24 21:58:02 +010045 exec = "${final.chromium}/bin/chromium --app=\"https://app.element.io/#/home\" --autoplay-policy=no-user-gesture-required --enable-features=WebUIDarkMode --force-dark-mode";
Skyler Greyffc104a2022-05-24 08:47:15 +010046 icon = "element";
47 type = "Application";
48 categories = "Network;InstantMessaging;";
49 terminal = "false";
50 };
51}