Skyler Grey | a7feb6e | 2022-08-26 06:51:55 +0100 | [diff] [blame] | 1 | { |
2 | pkgs, | ||||
3 | lib, | ||||
4 | ... | ||||
5 | }: { | ||||
6 | programs.neovim = { | ||||
7 | plugins = with pkgs.vimPlugins; [ | ||||
8 | (nvim-treesitter.withPlugins (plugins: | ||||
9 | (builtins.attrValues plugins) | ||||
10 | ++ (with pkgs.vimPlugins; [ | ||||
11 | nvim-ts-rainbow | ||||
12 | nvim-treesitter-refactor | ||||
13 | ]))) | ||||
14 | nvim-treesitter-context | ||||
15 | ]; | ||||
16 | extraConfig = '' | ||||
17 | source ${./setup.lua} | ||||
18 | ''; | ||||
19 | }; | ||||
20 | } |