blob: 948a224d00ad515128d82fb89b6637e6bbce8a7a [file] [log] [blame]
Skyler Grey51a0c612022-11-05 09:59:04 +00001{ lib, pkgs, ... }: {
2 home = {
3 services.picom = {
4 enable = true;
5 package = pkgs.picom-next;
6 experimentalBackends = true;
7 backend = "glx";
8 fade = true;
9 inactiveOpacity = 0.9;
10 vSync = true;
11 settings = {
12 blur.method = "dual_kawase";
13 corner-radius = 10;
14 glx-no-stencil = true;
15 unredir-if-possible = true;
16 use-damage = true;
17 no-fading-openclose = true;
18 fade-in-step = 0.005;
19 fade-out-step = 0.005;
20 no-fading-larger-than = 0.1;
21 rounded-corners-exclude = [
22 "class_g = 'Polybar'"
23 ];
24 };
25 };
26 systemd.user.services.picom.Install.WantedBy = lib.mkForce [ ];
27 };
28}