blob: 2c3c9c5f1cf3183be31b32f7631e06c4b84973f4 [file] [log] [blame]
Skyler Grey51a0c612022-11-05 09:59:04 +00001{ lib, pkgs, ... }: {
2 home = {
3 services.polybar = {
4 enable = true;
5 settings = {
6 "bar/main" = {
7 "inherit" = "base";
8 };
9 base = {
10 modules = {
11 left = "xmonad";
12 right = "date battery";
13 };
14 font = [
15 "Liga Roboto Mono:style=Regular:size=10;2"
16 "Twitter Color Emoji:style=Regular:antialias=false:scale=8;1"
17 ];
18 background = "\${colors.statusline}";
19 padding = 10;
20 module.margin = 5;
21 margin.bottom = "\${root.padding}";
22 tray.position = "right";
23 };
24 "module/xmonad" = {
25 type = "custom/script";
26 exec = "${pkgs.xmonad-log}/bin/xmonad-log";
27 tail = true;
28 };
29 "module/date" = {
30 type = "internal/date";
31 date = rec {
32 text = "%Y-%m-%d";
33 alt = text;
34 };
35 time = {
36 text = "%H:%M";
37 alt = "%H:%M:%S";
38 };
39 label = "%date% %time%";
40 };
Skyler Greyed5c5fc2023-02-26 13:00:06 +000041 "module/battery" = {
42 type = "internal/battery";
43 battery = "BAT1";
44 adapter = "ACAD";
45 };
Skyler Grey51a0c612022-11-05 09:59:04 +000046 colors = {
47 black = "#282c34";
48 red = "#e06c75";
49 green = "#98c379";
50 yellow = "#e5c07b";
51 blue = "#61afef";
52 purple = "#c678dd";
53 cyan = "#56b6c2";
54 statusline = "#313640";
55 lightgrey = "#474e5d";
56 darkred = "#844C55";
57 darkyellow = "#877658";
58 darkgreen = "#607857";
59 darkcyan = "#3F717B";
60 darkblue = "#456E92";
61 darkpurple = "#775289";
62 white = "#dcdfe4";
63 };
64 };
65 script = "polybar &";
Skyler Grey34021e32022-11-04 09:28:03 +000066 };
Skyler Grey51a0c612022-11-05 09:59:04 +000067 systemd.user.services.polybar.Install.WantedBy = lib.mkForce [ ];
Skyler Grey34021e32022-11-04 09:28:03 +000068 };
69}