blob: 8d78b1fa57b4ddaafca9478c78298d71a9494148 [file] [log] [blame]
Skyler Grey51a0c612022-11-05 09:59:04 +00001{ lib, pkgs, ... }: {
2 home = {
3 services.polybar = {
4 enable = true;
5 settings = {
6 "bar/main" = {
7 "inherit" = "base";
8 };
9 base = {
10 modules = {
11 left = "xmonad";
12 right = "date battery";
13 };
14 font = [
15 "Liga Roboto Mono:style=Regular:size=10;2"
16 "Twitter Color Emoji:style=Regular:antialias=false:scale=8;1"
17 ];
18 background = "\${colors.statusline}";
19 padding = 10;
20 module.margin = 5;
21 margin.bottom = "\${root.padding}";
22 tray.position = "right";
23 };
24 "module/xmonad" = {
25 type = "custom/script";
26 exec = "${pkgs.xmonad-log}/bin/xmonad-log";
27 tail = true;
28 };
29 "module/date" = {
30 type = "internal/date";
31 date = rec {
32 text = "%Y-%m-%d";
33 alt = text;
34 };
35 time = {
36 text = "%H:%M";
37 alt = "%H:%M:%S";
38 };
39 label = "%date% %time%";
40 };
41 "module/battery".type = "internal/battery";
42 colors = {
43 black = "#282c34";
44 red = "#e06c75";
45 green = "#98c379";
46 yellow = "#e5c07b";
47 blue = "#61afef";
48 purple = "#c678dd";
49 cyan = "#56b6c2";
50 statusline = "#313640";
51 lightgrey = "#474e5d";
52 darkred = "#844C55";
53 darkyellow = "#877658";
54 darkgreen = "#607857";
55 darkcyan = "#3F717B";
56 darkblue = "#456E92";
57 darkpurple = "#775289";
58 white = "#dcdfe4";
59 };
60 };
61 script = "polybar &";
Skyler Grey34021e32022-11-04 09:28:03 +000062 };
Skyler Grey51a0c612022-11-05 09:59:04 +000063 systemd.user.services.polybar.Install.WantedBy = lib.mkForce [ ];
Skyler Grey34021e32022-11-04 09:28:03 +000064 };
65}