Skyler Grey | cfee096 | 2022-08-19 22:40:53 +0100 | [diff] [blame] | 1 | { |
| 2 | description = "A basic flake with a shell"; |
| 3 | inputs.nixpkgs.url = "github:NixOS/nixpkgs/nixpkgs-unstable"; |
| 4 | inputs.flake-utils.url = "github:numtide/flake-utils"; |
| 5 | |
Skyler Grey | 252927a | 2022-10-18 22:18:15 +0100 | [diff] [blame] | 6 | outputs = |
| 7 | { self |
| 8 | , nixpkgs |
| 9 | , flake-utils |
| 10 | , |
| 11 | }: |
| 12 | flake-utils.lib.eachDefaultSystem (system: |
| 13 | let |
Skyler Grey | cfee096 | 2022-08-19 22:40:53 +0100 | [diff] [blame] | 14 | pkgs = nixpkgs.legacyPackages.${system}; |
Skyler Grey | 252927a | 2022-10-18 22:18:15 +0100 | [diff] [blame] | 15 | in |
| 16 | { |
Skyler Grey | cfee096 | 2022-08-19 22:40:53 +0100 | [diff] [blame] | 17 | devShell = pkgs.mkShell { |
Skyler Grey | 252927a | 2022-10-18 22:18:15 +0100 | [diff] [blame] | 18 | nativeBuildInputs = with pkgs; [ bashInteractive ncurses ]; |
| 19 | buildInputs = [ ]; |
Skyler Grey | cfee096 | 2022-08-19 22:40:53 +0100 | [diff] [blame] | 20 | }; |
| 21 | }); |
| 22 | } |