blob: 49806fda5fc56277af8a61fa1ad52d914c914297 [file] [log] [blame]
Skyler Greycfee0962022-08-19 22:40:53 +01001{
2 description = "A basic flake with a shell";
3 inputs.nixpkgs.url = "github:NixOS/nixpkgs/nixpkgs-unstable";
4 inputs.flake-utils.url = "github:numtide/flake-utils";
5
6 outputs = {
7 self,
8 nixpkgs,
9 flake-utils,
10 }:
11 flake-utils.lib.eachDefaultSystem (system: let
12 pkgs = nixpkgs.legacyPackages.${system};
13 in {
14 devShell = pkgs.mkShell {
15 nativeBuildInputs = with pkgs; [bashInteractive ncurses];
16 buildInputs = [];
17 };
18 });
19}