blob: 6f9d7681014c0c8217f71866678037e83eee8cd2 [file] [log] [blame]
Skyler Greyd4397f12022-10-31 00:27:35 +00001{ config, ... }: {
2 config = {
3 services.dnsmasq = {
4 enable = true;
5 servers = [ "1.1.1.1" "1.0.0.1" ];
6
7 extraConfig = ''
8 conf-file=${config.sops.secrets."dnsmasq-private.conf".path}
9 '';
10 };
11
12 sops.secrets."dnsmasq-private.conf" = {
13 format = "binary";
14 sopsFile = ../secrets/dnsmasq-private.conf;
15 };
16 };
17}