blob: 6469a1343c8af2f8f03bf0e7ac033bc03632091e [file] [log] [blame]
Skyler Turner62330c12022-03-04 22:10:16 +00001{
2 description = "Minion3665's NixFiles (since 2022-03-24)";
3
4 inputs = {
5 nixpkgs.url = "github:nixos/nixpkgs/nixos-21.11";
6 home-manager.url = "github:nix-community/home-manager/release-21.11";
7 };
8
9 outputs = { self, nixpkgs, home-manager }: {
10 let
11 system = "x86_64-linux"; # TOOD: Add options for MacOS
12
13 pkgs = nixpkgs {
14 inherit system;
15
16 config = { allowUnfree = true; };
17 };
18 in {
19 nixosConfigurations = {
20 default = pkgs.lib.nixosSystem {
21 inherit system;
22
23 modules = [
24 src/system.nix
25 ];
26 }
27 };
28
29 homeManagerConfiguration = {
30 minion = home-manager.lib.homeManagerConfiguration {
31 inherit system pkgs;
32
33 username = ""
34 }
35 }
36 };
37 };
38}