blob: eb7016e2c9a995be4d32711c7c6800ecd30f0baa [file] [log] [blame]
Skyler Turner62330c12022-03-04 22:10:16 +00001{
2 description = "Minion3665's NixFiles (since 2022-03-24)";
3
4 inputs = {
5 nixpkgs.url = "github:nixos/nixpkgs/nixos-21.11";
6 home-manager.url = "github:nix-community/home-manager/release-21.11";
7 };
8
9 outputs = { self, nixpkgs, home-manager }: {
10 let
11 system = "x86_64-linux"; # TOOD: Add options for MacOS
12
13 pkgs = nixpkgs {
14 inherit system;
15
16 config = { allowUnfree = true; };
17 };
18
19 variables = import ./src/common/variables.nix;a
20 in {
21 nixosConfigurations = {
22 default = pkgs.lib.nixosSystem {
23 inherit system;
24
25 modules = [
26 src/system.nix
27 ];
28 }
29 };
30
31 homeManagerConfiguration = {
32 minion = home-manager.lib.homeManagerConfiguration rec {
33 inherit system pkgs;
34
35 username = "minion";
36 homeDirectory = "/home/${username}";
37
38 configuration = {
39 imports = [
40 src/home.nix
41 ];
42 }
43
44 stateVersion = "21.11";
45 }
46 }
47 };
48 };
49}