blob: cd8f32690661939551a1a55b7f3e9a7d6a130189 [file] [log] [blame]
Skyler Turner62330c12022-03-04 22:10:16 +00001{ config, pkgs, nixpkgs }:
2let
3 variables = import ./common/variables.nix;
4in {
5 import = [
6 ./apps/personal/steam.nix
7
8 ];
9
10 nixpkgs.overlays = [
11 (import ./overlays/anytype.nix)
12 ];
13
14 home.packages = with pkgs; [ # New apps should be on new lines
15 anytype
16 minecraft
17 git-crypt gnupg pinentry_qt
18 keepassxc
19 grim slurp
20 neovim helix
21 qemu
22 bind
23 file
24 nur.repos.kira-bruneau.rofi-wayland
25 rofimoji
26 anytype-latest
27 htop
28 hue-cli
29 comma
30 zip
31 mindustry-alpha-wayland
32 nodejs-17_x
33 element
34 tdesktop
35 ]; # Use *only* for packages that need no configuration;
36 # other packages should go in ./apps/personal/
37
38 home.stateVersion = variables.stateVersion;
39}