blob: afbdd68ce5f9f8e444dc29661f443f85d9cf6b09 [file] [log] [blame]
Skyler Turner62330c12022-03-04 22:10:16 +00001{ config, pkgs, nixpkgs }:
2let
3 variables = import ./common/variables.nix;
4
5 =
6 let
7 toPkg = file: {
8 name = builtins.replaceStrings [ ".nix" ] [ "" ] file;
9 value = import (./. + "/pkgConfigs/${file}") { };
10 };
11 in
12 pkgs.lib.mapAttrs' toPkg (builtins.readDir (./. + "/pkgConfigs"));
13 in
14 { imports = generatedPkgs; }
15
16in {
17 import = [
18 ./apps/personal/steam.nix
19
20 ];
21
22 nixpkgs.overlays = [
23 (import ./overlays/anytype.nix)
24 ];
25
26 home.packages = with pkgs; [ # New apps should be on new lines
27 anytype
28 minecraft
29 nodejs-17_x
30
31 git-crypt gnupg pinentry_qt
32 keepassxc
33 grim slurp
34 neovim helix
35 qemu
36 bind
37 file
38 nur.repos.kira-bruneau.rofi-wayland
39 rofimoji
40 anytype-latest
41 htop
42 hue-cli
43 comma
44 zip
45 mindustry-alpha-wayland
46 element
47 tdesktop
48 ]; # Use *only* for packages that need no configuration;
49 # other packages should go in ./apps/personal/
50
51 home.stateVersion = variables.stateVersion;
52}