blob: 6843da412e38afae0e23e02f85e1b5ab03d98b50 [file] [log] [blame]
Skyler Turner62330c12022-03-04 22:10:16 +00001{ config, pkgs, nixpkgs }:
2let
3 variables = import ./common/variables.nix;
4 personalPackages = let
5 toPkg = file: {
6 name = builtins.replaceStrings [ ".nix" ] [ "" ] file;
7 value = import (./. + "/pkgConfigs/${file}") { };
8 };
9 in
10 pkgs.lib.mapAttrs' toPkg (builtins.readDir (./. + "/pkgConfigs"));
11in {
12 import = [
13 ./apps/personal/steam.nix
14
15 ];
16
17 nixpkgs.overlays = [
18 (import ./overlays/anytype.nix)
19 ];
20
21 home.packages = with pkgs; [ # New apps should be on new lines
22 anytype
23 minecraft
24 nodejs-17_x
25
26 git-crypt gnupg pinentry_qt
27 keepassxc
28 grim slurp
29 neovim helix
30 qemu
31 bind
32 file
33 nur.repos.kira-bruneau.rofi-wayland
34 rofimoji
35 anytype-latest
36 htop
37 hue-cli
38 comma
39 zip
40 mindustry-alpha-wayland
41 element
42 tdesktop
43 ]; # Use *only* for packages that need no configuration;
44 # other packages should go in ./apps/personal/
45
46 home.stateVersion = variables.stateVersion;
47}