blob: b70d6397dc3c31ff933a2bba9438d23baadbd192 [file] [log] [blame]
Skyler Turnercddb5c42022-05-14 01:17:44 +01001{ pkgs, ... }: {
Skyler Greye11b9a72022-05-31 14:29:27 +01002 programs.kitty = {
3 enable = true;
4
5 theme = "One Half";
Skyler Greyc3585f12022-05-31 15:41:17 +01006
7 settings = {
8 enable_audio_bell = "no";
9 visual_bell_duration = "0.1";
Skyler Grey66b782f2022-08-12 13:55:11 +010010 symbol_map = "U+E0A0-U+E0A3,U+E0C0-U+E0C7 PowerlineSymbols";
Skyler Greyc3585f12022-05-31 15:41:17 +010011 };
Skyler Greye11b9a72022-05-31 14:29:27 +010012 };
13
14 programs.zsh.initExtra = ''
15 if test -n "$KITTY_INSTALLATION_DIR"; then
16 export KITTY_SHELL_INTEGRATION="enabled"
17 autoload -Uz -- "$KITTY_INSTALLATION_DIR"/shell-integration/zsh/kitty-integration
18 kitty-integration
19 unfunction kitty-integration
20 fi
Skyler Grey38b468f2022-08-11 11:57:28 +010021 '';
22
23 home.shellAliases = {
24 "icat" = "${pkgs.kitty}/bin/kitty +kitten icat";
25 };
Skyler Turnercddb5c42022-05-14 01:17:44 +010026}