Skyler Grey | 8964db5 | 2023-03-19 19:46:44 +0000 | [diff] [blame] | 1 | { pkgs, ... }: { |
| 2 | home = { |
| 3 | programs.wezterm = { |
| 4 | enable = true; |
| 5 | |
| 6 | extraConfig = '' |
| 7 | return { |
| 8 | color_scheme = "OneHalfDark", |
| 9 | visual_bell = { |
| 10 | fade_in_duration_ms = 50, |
| 11 | fade_out_duration_ms = 50, |
| 12 | }, |
| 13 | window_padding = { |
| 14 | left = '0.5cell', |
| 15 | right = '0.5cell', |
| 16 | top = '3px', |
| 17 | bottom = '3px', |
| 18 | }, |
| 19 | hide_tab_bar_if_only_one_tab = true, |
| 20 | window_frame = { |
| 21 | active_titlebar_bg = '#313640', |
| 22 | inactive_titlebar_bg = '#313640', |
| 23 | }, |
| 24 | colors = { |
| 25 | tab_bar = { |
| 26 | inactive_tab = { |
| 27 | bg_color = '#474e5d', |
| 28 | fg_color = 'white', |
| 29 | }, |
| 30 | new_tab = { |
| 31 | bg_color = '#474e5d', |
| 32 | fg_color = 'white', |
| 33 | }, |
| 34 | active_tab = { |
| 35 | bg_color = '#98c379', |
| 36 | fg_color = '#474e5d', |
| 37 | }, |
| 38 | }, |
| 39 | }, |
| 40 | default_cursor_style = 'BlinkingBar', |
| 41 | cursor_blink_rate = 600, |
| 42 | cursor_blink_ease_in = 'Constant', |
| 43 | cursor_blink_ease_out = 'Constant', |
| 44 | } |
| 45 | ''; |
| 46 | }; |
| 47 | home.shellAliases = { |
| 48 | icat = "wezterm imgcat"; |
| 49 | imgcat = "wezterm imgcat"; |
| 50 | }; |
| 51 | }; |
| 52 | } |