Skyler Grey | 42f6073 | 2022-08-26 06:45:17 +0100 | [diff] [blame] | 1 | { |
2 | pkgs, | ||||
3 | config, | ||||
4 | username, | ||||
5 | lib, | ||||
6 | ... | ||||
7 | }: let | ||||
8 | cfg = config.minion.emacs; | ||||
9 | in { | ||||
10 | options.minion.emacs.enable = lib.mkEnableOption "Enable emacs"; | ||||
11 | |||||
12 | config = { | ||||
13 | environment.persistence."/nix/persist".users.${username}.directories = [".emacs.d"]; | ||||
14 | }; | ||||
15 | |||||
16 | home.programs.emacs.enable = true; | ||||
17 | |||||
18 | traces = [ | ||||
19 | "home.programs.emacs.enable" | ||||
20 | ]; | ||||
21 | } |