blob: b29a6aafd07df1b04fcc11e03e08c3c08aabeac6 [file] [log] [blame]
Skyler Greya7feb6e2022-08-26 06:51:55 +01001{
2 pkgs,
3 lib,
4 ...
Skyler Greyf8194602022-10-31 00:07:05 +00005}: let
6 disabledGrammars = [
7 "tree-sitter-sql"
8 ];
9in {
Skyler Greya7feb6e2022-08-26 06:51:55 +010010 programs.neovim = {
11 plugins = with pkgs.vimPlugins; [
12 (nvim-treesitter.withPlugins (plugins:
Skyler Greyf8194602022-10-31 00:07:05 +000013 (lib.pipe plugins [
14 (lib.filterAttrs (name: value: !builtins.elem name disabledGrammars))
15 builtins.attrValues
16 ])
Skyler Greya7feb6e2022-08-26 06:51:55 +010017 ++ (with pkgs.vimPlugins; [
18 nvim-ts-rainbow
Skyler Greya7feb6e2022-08-26 06:51:55 +010019 ])))
20 nvim-treesitter-context
21 ];
22 extraConfig = ''
23 source ${./setup.lua}
24 '';
25 };
26}