blob: f285b7cdbd389108529e05357e3720997ab4a080 [file] [log] [blame]
Skyler Grey1010db92022-09-05 03:21:48 +01001{
2 pkgs,
3 username,
4 ...
5}: {
Skyler Grey944dfa22022-09-01 23:47:48 +01006 config = {
7 programs.steam = {
8 enable = true;
9 remotePlay.openFirewall = true;
10 };
11 hardware.steam-hardware.enable = true;
12
13 internal.allowUnfree = ["steam" "steam-original" "steam-runtime"];
Skyler Grey7c61e7a2022-10-31 00:22:11 +000014 environment = {
15 persistence."/large/persist".users.${username}.directories = [".local/share/Steam"];
16 systemPackages = with pkgs; [gamescope gamemode /*(
17 writeTextDir "share/applications/steam.desktop" ''
18 [Desktop Entry]
19 Name=Steam
20 Comment=Application for managing and playing games on steam
21 Exec=${pkgs.gamescope}/bin/gamescope -w 1920 -h 1080 -- ${pkgs.steam}/bin/steam
22 Icon=steam
23 Terminal=false
24 Type=Application
25 Categories=Network;FileTransfer;Game;
26 MimeType=x-scheme-handler/steam;x-scheme-handler/steamlink;
27 Actions=Store;Community;Library;Servers;Screenshots;News;Settings;BigPicture;Friends;
28 PrefersNonDefaultGPU=true
29 X-KDE-RunOnDiscreteGpu=true
30 ''
31 )*/];
32 };
33 boot.kernel.sysctl."dev.i915.perf_stream_paranoid" = "0";
Skyler Grey944dfa22022-09-01 23:47:48 +010034 };
35}