blob: bb96c12a6269594366f1911d230dbdee25d7e8ff [file] [log] [blame]
Skyler Grey7daf10f2023-02-26 12:55:17 +00001{ rustPlatform
2, fetchFromGitHub
3, cmake
4, pkg-config
5, system
6, _tooling
7,
8}: let
9 craneLib = _tooling.crane.lib.${system};
10 rev = "71638e6540e2fc30bd609f8f78131ec10217f906";
11in craneLib.buildPackage {
12 pname = "tcount";
13 version = builtins.substring 0 7 rev;
14
15 src = craneLib.cleanCargoSource (fetchFromGitHub {
16 owner = "RRethy";
17 repo = "tcount";
18 inherit rev;
19 sha256 = "sha256-PrRfk/4wRADNASLmcPIpxs+flAd3S/k1OWBaY3GRJHE=";
20 });
21
22 nativeBuildInputs = [
23 cmake
24 pkg-config
25 ];
26
27 doCheck = false;
28}