Skyler Grey | 7daf10f | 2023-02-26 12:55:17 +0000 | [diff] [blame] | 1 | { rustPlatform |
| 2 | , fetchFromGitHub |
| 3 | , cmake |
| 4 | , pkg-config |
| 5 | , system |
| 6 | , _tooling |
| 7 | , |
| 8 | }: let |
| 9 | craneLib = _tooling.crane.lib.${system}; |
| 10 | rev = "71638e6540e2fc30bd609f8f78131ec10217f906"; |
| 11 | in craneLib.buildPackage { |
| 12 | pname = "tcount"; |
| 13 | version = builtins.substring 0 7 rev; |
| 14 | |
| 15 | src = craneLib.cleanCargoSource (fetchFromGitHub { |
| 16 | owner = "RRethy"; |
| 17 | repo = "tcount"; |
| 18 | inherit rev; |
| 19 | sha256 = "sha256-PrRfk/4wRADNASLmcPIpxs+flAd3S/k1OWBaY3GRJHE="; |
| 20 | }); |
| 21 | |
| 22 | nativeBuildInputs = [ |
| 23 | cmake |
| 24 | pkg-config |
| 25 | ]; |
| 26 | |
| 27 | doCheck = false; |
| 28 | } |