blob: a5469f43a47b4372d5d282a037bff4fab88ef4ab [file] [log] [blame]
Skyler Grey14027172023-01-15 09:49:53 +00001{ pkgs, lanzaboote, lib, ... }: {
2 imports = [
3 lanzaboote.nixosModules.lanzaboote
4 ];
5 config = {
6 boot = {
7 bootspec.enable = true;
8 loader.systemd-boot.enable = lib.mkForce false;
9 lanzaboote = {
10 enable = true;
11 pkiBundle = "/etc/secureboot";
12 };
13 };
14
15 environment = {
16 persistence."/nix/persist".directories = [
17 "/etc/secureboot"
18 ];
19 systemPackages = [ pkgs.sbctl ];
20 };
21 };
22}