blob: 50a076dc2d44a37bf9d4cbc1bf1bc642d738abe4 [file] [log] [blame]
Skyler Grey8dee1c02022-08-01 09:36:38 +01001{ pkgs, ... }: let
2 config = { configFile, instanceName }: { pkgs, ... }: {
3 imports = [
4 configFile
5 ];
6
7 _module.args = { instance = instanceName; inputs = {}; };
8 };
9
10in {
Skyler Grey6d2d67a2022-07-31 21:15:48 +010011 containers.caddy = {
12 autoStart = false;
13 privateNetwork = true;
Skyler Grey8dee1c02022-08-01 09:36:38 +010014 localAddress = "10.0.108.2";
15 hostAddress = "10.0.108.1";
16 config = config {
17 configFile = /home/minion/Code/nix/oss-labs.eu/hosts/caddy/default.nix;
18 instanceName = "caddy";
19 };
Skyler Grey6d2d67a2022-07-31 21:15:48 +010020 };
21
22 containers.collabora = {
23 autoStart = false;
24 privateNetwork = true;
Skyler Grey8dee1c02022-08-01 09:36:38 +010025 localAddress = "10.0.108.3";
26 hostAddress = "10.0.108.1";
27 config = config {
28 configFile = /home/minion/Code/nix/oss-labs.eu/hosts/collabora/default.nix;
29 instanceName = "collabora";
30 };
31 };
32
33 networking.nat = {
34 enable = true;
35 internalInterfaces = [ "ve-+" ];
36 externalInterface = "wlan0";
37 };
38
39 networking.hosts = {
40 "10.0.108.2" = [ "collabora.oss-labs.eu" "meet.oss-labs.eu" "notes.oss-labs.eu" ];
Skyler Grey6d2d67a2022-07-31 21:15:48 +010041 };
42}