Skyler Grey | 86cb60e | 2022-09-01 23:55:12 +0100 | [diff] [blame] | 1 | {pkgs, ...}: { |
| 2 | config.fonts = { |
| 3 | fonts = with pkgs; [ |
| 4 | roboto |
| 5 | roboto-mono |
| 6 | roboto-slab |
| 7 | twitter-color-emoji |
| 8 | font-awesome |
| 9 | material-design-icons |
| 10 | powerline-symbols |
Skyler Grey | f6d6986 | 2022-09-11 00:39:50 +0100 | [diff] [blame] | 11 | nerdfonts-glyphs |
Skyler Grey | 86cb60e | 2022-09-01 23:55:12 +0100 | [diff] [blame] | 12 | ]; |
| 13 | |
| 14 | fontDir.enable = true; |
| 15 | enableDefaultFonts = true; |
| 16 | |
| 17 | fontconfig.defaultFonts = { |
| 18 | serif = ["Roboto Slab"]; |
Skyler Grey | f6d6986 | 2022-09-11 00:39:50 +0100 | [diff] [blame] | 19 | sansSerif = ["Roboto" "Symbols Nerd Font"]; |
| 20 | monospace = ["Roboto Mono" "Symbols Nerd Font"]; |
Skyler Grey | 86cb60e | 2022-09-01 23:55:12 +0100 | [diff] [blame] | 21 | emoji = ["Twitter Color Emoji"]; |
| 22 | }; |
| 23 | }; |
| 24 | } |