Skyler Grey | 2a7ca38 | 2022-09-01 23:15:31 +0100 | [diff] [blame] | 1 | { |
| 2 | pkgs, |
| 3 | username, |
| 4 | gtimelog, |
| 5 | lib, |
| 6 | ... |
| 7 | }: { |
| 8 | home.home = { |
| 9 | packages = [ |
| 10 | (pkgs.gtimelog.overrideAttrs (oldAttrs: { |
| 11 | src = gtimelog; |
| 12 | makeWrapperArgs = [ |
Skyler Grey | 2a7ca38 | 2022-09-01 23:15:31 +0100 | [diff] [blame] | 13 | "--set GIO_MODULE_DIR ${lib.makeSearchPathOutput "out" |
| 14 | "lib/gio/modules" (with pkgs; [ |
| 15 | glib-networking |
| 16 | ])}" |
| 17 | ]; |
Skyler Grey | e1d081f | 2022-09-07 02:00:25 +0100 | [diff] [blame] | 18 | nativeBuildInputs = oldAttrs.nativeBuildInputs ++ [pkgs.gobject-introspection]; |
Skyler Grey | 2a7ca38 | 2022-09-01 23:15:31 +0100 | [diff] [blame] | 19 | buildInputs = oldAttrs.buildInputs ++ [pkgs.glib-networking]; |
| 20 | })) |
| 21 | ]; |
| 22 | file.".gtimelog/gtimelogrc".source = ./gtimelog/gtimelogrc.toml; |
| 23 | }; |
| 24 | |
| 25 | config.environment.persistence."/nix/persist".users.${username}.directories = [".gtimelog"]; |
| 26 | } |