blob: c591e1ce72d736b391a1431bf2bf7c5e7c7aed6a [file] [log] [blame]
Skyler Grey252927a2022-10-18 22:18:15 +01001{ lib
2, fetchFromGitHub
3, stdenv
4,
Skyler Grey95c67e02022-10-30 22:28:42 +00005}:
6stdenv.mkDerivation rec {
7 pname = "monocraft";
8 version = "1.2";
9
10 src = fetchFromGitHub {
11 owner = "IdreesInc";
12 repo = "Monocraft";
13 rev = "v${version}";
Skyler Grey0c7d0922022-10-30 22:59:22 +000014 sha256 = "sha256-frg7LcMv6zWPWxkr6RIl01fC68THELbb45mJVqefXC0=";
Skyler Grey95c67e02022-10-30 22:28:42 +000015 };
16
17 dontBuild = true;
18
19 installPhase = ''
20 mkdir -p $out/bin $out/share/fonts/opentype
21 mv Monocraft.otf $out/share/fonts/opentype
22 '';
23
24 meta = with lib; {
25 description = "A programming font based on the typeface used in Minecraft";
26 homepage = "https://github.com/IdreesInc/Monocraft";
27 license = licenses.ofl;
Skyler Grey252927a2022-10-18 22:18:15 +010028 maintainers = with maintainers; [ minion3665 ];
Skyler Grey95c67e02022-10-30 22:28:42 +000029 };
30}