Skyler Grey | 252927a | 2022-10-18 22:18:15 +0100 | [diff] [blame] | 1 | { rustPlatform |
| 2 | , fetchFromGitHub |
| 3 | , cmake |
| 4 | , pkg-config |
| 5 | , freetype |
| 6 | , fontconfig |
| 7 | , expat |
| 8 | , wayland |
| 9 | , system |
| 10 | , |
Skyler Grey | b562da3 | 2022-09-01 23:36:28 +0100 | [diff] [blame] | 11 | }: |
| 12 | rustPlatform.buildRustPackage rec { |
| 13 | pname = "waycorner"; |
| 14 | version = builtins.substring 0 7 src.rev; |
| 15 | |
| 16 | src = fetchFromGitHub { |
| 17 | owner = "Minion3665"; |
| 18 | repo = "waycorner"; |
Skyler Grey | f4c2e67 | 2022-10-31 00:29:45 +0000 | [diff] [blame] | 19 | rev = "ef3bd723a9a8673328c12fc8c7f210864787e5d1"; |
| 20 | sha256 = "sha256-iPeF84tC3IEYECm04KwmTjOaYVSUMh2dBlijzGnxoyw="; |
Skyler Grey | b562da3 | 2022-09-01 23:36:28 +0100 | [diff] [blame] | 21 | }; |
| 22 | |
| 23 | cargoLock.lockFile = "${src}/Cargo.lock"; |
| 24 | |
| 25 | nativeBuildInputs = [ |
| 26 | cmake |
| 27 | pkg-config |
| 28 | ]; |
Skyler Grey | 1010db9 | 2022-09-05 03:21:48 +0100 | [diff] [blame] | 29 | |
Skyler Grey | b562da3 | 2022-09-01 23:36:28 +0100 | [diff] [blame] | 30 | buildInputs = [ |
| 31 | freetype |
| 32 | fontconfig |
| 33 | expat |
| 34 | wayland |
| 35 | ]; |
| 36 | |
| 37 | postFixup = '' |
| 38 | patchelf --add-needed ${wayland}/lib/libwayland-client.so $out/bin/waycorner |
| 39 | ''; |
| 40 | } |