Skyler Turner | 62330c1 | 2022-03-04 22:10:16 +0000 | [diff] [blame] | 1 | { config, pkgs, nixpkgs }: |
| 2 | let |
| 3 | variables = import ./common/variables.nix; |
| 4 | personalPackages = let |
| 5 | toPkg = file: { |
| 6 | name = builtins.replaceStrings [ ".nix" ] [ "" ] file; |
| 7 | value = "./apps/personal/${file}"; |
| 8 | }; |
| 9 | in pkgs.lib.mapAttrs' toPkg (builtins.readDir (./. + "/apps/personal/")); |
| 10 | in { |
| 11 | import = personalPackages; |
| 12 | |
| 13 | nixpkgs.overlays = [ |
| 14 | (import ./overlays/anytype.nix) |
| 15 | ]; |
| 16 | |
| 17 | home.packages = with pkgs; [ # New apps should be on new lines |
| 18 | anytype |
| 19 | minecraft |
| 20 | nodejs-17_x |
| 21 | |
| 22 | git-crypt |
| 23 | keepassxc |
| 24 | grim slurp |
| 25 | neovim helix |
| 26 | qemu |
| 27 | bind |
| 28 | file |
| 29 | nur.repos.kira-bruneau.rofi-wayland |
| 30 | rofimoji |
| 31 | anytype-latest |
| 32 | htop |
| 33 | hue-cli |
Skyler Turner | 62330c1 | 2022-03-04 22:10:16 +0000 | [diff] [blame] | 34 | zip |
| 35 | mindustry-alpha-wayland |
| 36 | element |
| 37 | tdesktop |
| 38 | ]; # Use *only* for packages that need no configuration; |
| 39 | # other packages should go in ./apps/personal/ |
| 40 | |
| 41 | home.stateVersion = variables.stateVersion; |
| 42 | } |