Skyler Grey | 7dfe5c6 | 2022-08-20 21:41:30 +0100 | [diff] [blame] | 1 | { |
| 2 | pkgs, |
| 3 | registry, |
Skyler Grey | ff3c6a2 | 2022-08-21 07:25:02 +0100 | [diff] [blame] | 4 | nixpkgs, |
Skyler Grey | 7dfe5c6 | 2022-08-20 21:41:30 +0100 | [diff] [blame] | 5 | ... |
| 6 | }: { |
| 7 | config = { |
| 8 | nix = { |
Skyler Grey | ff3c6a2 | 2022-08-21 07:25:02 +0100 | [diff] [blame] | 9 | registry.nixpkgs.flake = nixpkgs; |
Skyler Grey | 7dfe5c6 | 2022-08-20 21:41:30 +0100 | [diff] [blame] | 10 | settings = { |
| 11 | experimental-features = ["nix-command" "flakes"]; |
| 12 | auto-optimise-store = true; |
| 13 | keep-outputs = true; |
| 14 | flake-registry = "${registry}/flake-registry.json"; |
| 15 | }; |
| 16 | gc = { |
| 17 | automatic = true; |
| 18 | options = "--delete-older-than 7d"; |
| 19 | }; |
Skyler Grey | 5b75372 | 2022-08-26 07:53:33 +0100 | [diff] [blame] | 20 | package = pkgs.nix; |
Skyler Grey | 7dfe5c6 | 2022-08-20 21:41:30 +0100 | [diff] [blame] | 21 | }; |
Skyler Grey | f4a835a | 2022-08-20 22:30:48 +0100 | [diff] [blame] | 22 | |
| 23 | # This value determines the NixOS release from which the default |
| 24 | # settings for stateful data, like file locations and database versions |
| 25 | # on your system were taken. It‘s perfectly fine and recommended to leave |
| 26 | # this value at the release version of the first install of this system. |
| 27 | # Before changing this value read the documentation for this option |
| 28 | # (e.g. man configuration.nix or on https://nixos.org/nixos/options.html). |
| 29 | system.stateVersion = "22.05"; # Did you read the comment? |
| 30 | }; |
| 31 | |
| 32 | home = { |
| 33 | home.stateVersion = "22.05"; |
Skyler Grey | 7dfe5c6 | 2022-08-20 21:41:30 +0100 | [diff] [blame] | 34 | }; |
| 35 | } |