blob: dfb97d89e33c4bf6d00984143bab5b7cc1a4cdf6 [file] [log] [blame]
Skyler Turnercddb5c42022-05-14 01:17:44 +01001{ pkgs, ... }: {
Skyler Greye11b9a72022-05-31 14:29:27 +01002 programs.kitty = {
3 enable = true;
4
5 theme = "One Half";
Skyler Greyc3585f12022-05-31 15:41:17 +01006
7 settings = {
8 enable_audio_bell = "no";
9 visual_bell_duration = "0.1";
10 };
Skyler Greye11b9a72022-05-31 14:29:27 +010011 };
12
13 programs.zsh.initExtra = ''
14 if test -n "$KITTY_INSTALLATION_DIR"; then
15 export KITTY_SHELL_INTEGRATION="enabled"
16 autoload -Uz -- "$KITTY_INSTALLATION_DIR"/shell-integration/zsh/kitty-integration
17 kitty-integration
18 unfunction kitty-integration
19 fi
Skyler Grey38b468f2022-08-11 11:57:28 +010020 '';
21
22 home.shellAliases = {
23 "icat" = "${pkgs.kitty}/bin/kitty +kitten icat";
24 };
Skyler Turnercddb5c42022-05-14 01:17:44 +010025}