Skyler Turner | 62330c1 | 2022-03-04 22:10:16 +0000 | [diff] [blame] | 1 | { config, pkgs, nixpkgs }: |
| 2 | let |
| 3 | variables = import ./common/variables.nix; |
| 4 | in { |
| 5 | |
| 6 | nixpkgs.overlays = [ |
| 7 | (import ./overlays/anytype.nix) |
| 8 | ]; |
| 9 | |
| 10 | home.packages = with pkgs; [ |
| 11 | anytype |
| 12 | |
| 13 | steam-tui steam-run |
| 14 | minecraft |
| 15 | git-crypt gnupg pinentry_qt |
| 16 | spotify |
| 17 | keepassxc |
| 18 | grim slurp |
| 19 | neovim helix |
| 20 | qemu |
| 21 | bind |
| 22 | file |
| 23 | nur.repos.kira-bruneau.rofi-wayland |
| 24 | rofimoji |
| 25 | anytype-latest |
| 26 | htop |
| 27 | hue-cli |
| 28 | comma |
| 29 | zip |
| 30 | mindustry-alpha-wayland |
| 31 | nodejs-17_x |
| 32 | element |
| 33 | tdesktop |
| 34 | ]; # Use *only* for packages that need no configuration; |
| 35 | # other packages should go in ./apps/personal/ |
| 36 | |
| 37 | home.stateVersion = variables.stateVersion; |
| 38 | } |